Browse Source

re-enable percy checks on PRs

pull/626/head
Jake Jarvis 3 months ago
parent
commit
302a88d6ff
Signed by: jake GPG Key ID: 2B0C9CF251E69A39
  1. 23
      .env.example
  2. 1
      .github/workflows/ci.yml
  3. 16
      package.json
  4. 1092
      yarn.lock

23
.env.example

@ -1,18 +1,21 @@
FAUNADB_ADMIN_SECRET=
# Production:
AIRTABLE_API_KEY=
AIRTABLE_BASE=
FAUNADB_SERVER_SECRET=
GH_PUBLIC_TOKEN=
HCAPTCHA_SITE_KEY=
HCAPTCHA_SECRET_KEY=
SENTRY_DSN=
SPOTIFY_REFRESH_TOKEN=
SPOTIFY_CLIENT_SECRET=
SPOTIFY_CLIENT_ID=
WEBMENTIONS_TOKEN=
PERCY_TOKEN=
LHCI_SERVER_BASE_URL=
LHCI_TOKEN=
# CI:
LHCI_ADMIN_TOKEN=
LHCI_GITHUB_APP_TOKEN=
LHCI_TOKEN=
SENTRY_AUTH_TOKEN=
SENTRY_DSN=
AIRTABLE_API_KEY=
AIRTABLE_BASE=
HCAPTCHA_SITE_KEY=
HCAPTCHA_SECRET_KEY=
PERCY_TOKEN=
WEBMENTIONS_TOKEN=

1
.github/workflows/ci.yml

@ -25,6 +25,5 @@ jobs:
SKIP_OPTIMIZE_IMAGES: true
- run: yarn lint
- run: npx -p @percy/cli percy snapshot ./public
if: github.actor == 'jakejarvis'
env:
PERCY_TOKEN: ${{ secrets.PERCY_TOKEN }}

16
package.json

@ -38,7 +38,7 @@
"fast-xml-parser": "^3.21.0",
"faunadb": "^4.4.1",
"get-canonical-url": "^1.0.1",
"graphql": "^15.7.0",
"graphql": "^16.0.0",
"graphql-request": "^3.6.1",
"graphql-tag": "^2.12.5",
"html-entities": "^2.3.2",
@ -55,14 +55,14 @@
"vanilla-hcaptcha": "^1.0.0-alpha"
},
"devDependencies": {
"@babel/core": "^7.15.8",
"@babel/eslint-parser": "^7.15.8",
"@babel/preset-env": "^7.15.8",
"@babel/core": "^7.16.0",
"@babel/eslint-parser": "^7.16.0",
"@babel/preset-env": "^7.16.0",
"@jakejarvis/eslint-config": "github:jakejarvis/eslint-config#main",
"@types/numeral": "^2.0.2",
"@types/twemoji": "^12.1.2",
"@types/url-parse": "^1.4.4",
"autoprefixer": "^10.3.7",
"autoprefixer": "^10.4.0",
"babel-loader": "^8.2.3",
"babel-plugin-template-html-minifier": "^4.1.0",
"clean-css": "^5.2.2",
@ -99,7 +99,7 @@
"postcss-merge-rules": "^5.0.2",
"postcss-normalize-charset": "^5.0.1",
"postcss-reporter": "^7.0.4",
"postcss-scss": "^4.0.1",
"postcss-scss": "^4.0.2",
"postcss-svgo": "^5.0.2",
"prettier": "^2.4.1",
"sass": "^1.43.4",
@ -114,10 +114,10 @@
"stylelint-scss": "~4.0.0",
"terser": "^5.9.0",
"terser-webpack-plugin": "^5.2.4",
"webpack": "^5.60.0",
"webpack": "^5.61.0",
"webpack-assets-manifest": "^5.0.6",
"webpack-cli": "^4.9.1",
"webpack-dev-server": "^4.3.1"
"webpack-dev-server": "^4.4.0"
},
"optionalDependencies": {
"imagemin-gifsicle": "^7.0.0",

1092
yarn.lock

File diff suppressed because it is too large
Loading…
Cancel
Save